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1 Introduction

Hyperland  is  a  shareware  program  ($25)  that  allows  you  to
maintain a dive log and download data from a popular scuba dive
watch (The Citizen Watch Co. currently has concerns about Mac
software  downloading  from  the  Hyper  Aqualand™  watch.
Therefore,  no  claims  are  made  here  concerning  the  Transfer
function in this software). Hyperland can plot your dive profile and
save  the  dive  log  info  to  a  file.  Information  from  the  watch
includes:  Date,  dive number,  dive time,  surface interval,  water
temperature,  max.  depth,  average depth,  depth  data  collected
every  5  seconds  and  water  temperature  every  5  minutes.
Additional information can be added. i.e.. Name, Buddy, Location,
Temperature, Air Consumption, Purpose, Visibility, Tank Pressures
and Weights.  Remarks can be quickly entered by selecting from
list based menus or by typing in text. Hyperland supports System
7 Finder features: Drag and Drop, Printing and Double Clicking.

Each dive is kept as a single file.  When a dive is called up, it is
displayed with a dive info text above a plot area. Buddy, location,
conditions, visibility, air consumption and notes can be entered
and later modified.

The dive profile area is a plot of the depth and water temperature
vs. time..  As you move the cursor over the plot area, the cursor
will change to cross-hairs to allow you to select a point on the plot
and get the corresponding time, depth and water temperature.
e.g.:

[62]  5’10” 48’ 74°F 
would mean that data point 62 at time 5 minutes and 10 seconds
into the dive, the depth was 48 feet and the water temperature
was 74 degrees Farenheit.  The resolution of the displayed time
can not be less than 5 seconds since that is the sampling rate of
the watch.  Data can also be viewed in the metric system.

A print capability allows you to get a printout of one or several
dives.

Existing dive files from a PC can be Imported into Hyperland.  Files



can also be exported from Hyperland for  use on a PC.   A tab
separated  file  can  be  exported  for  use  in  a  spreadsheet  or
database application. 



2 Adding a Dive Log Entry

There are two ways of entering a Dive Log Entry.  If you have a
Hyper Aqualand™ watch, you can download data from the watch
directly  (see  “Downloading  From  the  Watch”,  below)  .
Alternatively, you can create a new entry by selecting New File...
from the File menu.  

You can then enter the Dive’s Date, Dive Series#, Start Time, End
Time, Surface Interval,  the Average Depth of the dive (used to
calculate you air consumption Rates), Maximum Depth, and Water
Temperature:

The dive number here is the dive number within a series.  In the
above example, this is the second dive of the day.  An absolute
dive number can be entered in the Modify form.

To Modify dive information, select ⌘M, or Modify from the Data
Menu.

Portions of the Modify form are shown and discussed:



In  the  field  Diver,  type  in  the  diver’s  name.   Other  entries:
Location: enter where you dove.  Purpose: could be an activity
that’s  can’t  be  selected  from  the  Activity  menu  (below).
Conditions:  additional  info  that  can’t  be  selected  from  the
condition menus (below).  Remarks: Type in anything you like.

Dive:  is  the  absolute  dive  number  from  the  time  you  started
scuba  diving.   Buddy:  Your  buddy’s  name.  Air  Temp:   The  air
temperature.



Air Start: Your tank pressure when you started.  End: Your tank
pressure when you ended the dive (used in calculating you Air
Consumption Rates).  Tank Size: Your tank size.

Belt Weight: Amount of weight on your weight belt.  Ankle Weight:
Amount  of  weight  on  you ankles  (if  used).   Weight  Comment:
Select from the pop-up menu the appropriate comment on the
amount of weight used.

Weather, Water, Entry, Bottom and Tide: Select from the pop-up
menu  the  appropriate  comment.   Visibily:  In  addition  to  a
comment, you can enter an approximate distance for visibility.



Dive Time, Activity, Protection, Currents, Surge and Surf: Select
from the pop-up menu the appropriate comment.  A blank entry is
available if a comment does not apply.

3 Downloading From the Watch

Start up the Hyperland application. 

Connect the watch cradle to your Mac’s printer or modem port
using a standard Modem Serial Cable (8 Din Male to DB25 Male;
see "Troubleshooting" below).

From the Preferences Menu, use the Select Port to select which
port  you are using.   For  PowerBooks,  the port  to  select  is  the
Modem Port even if you are connected to your printer port.

Place  the  watch  in  transfer  mode:   From any  mode,  hold  the
MODE  button  for  2  seconds.   TR  should  be  displayed  in  the
watch’s message area. 

Select which dive you wish to download by pressing the LIGHT or
SET buttons to cycle through the dives.  LIGHT moves ahead in
time to newer dives. SET moves back in time to older dives.

Place  the  watch  in  the  interface  cradle  so  that  the  watch’s
connection side (arrow on watch face points there) is in secure
contact with the cradle’s pins.

Select ⌘T, or Transfer... from the Data Menu.

If  you  have  a  proper  connection,  the  watch  will  display  BUSY
during the transfer. If the transfer was successful, you will hear
the watch beep and a Dialog window will advise you.  Usually, the
first transfer on my watch is not successful, but subsequent ones
are OK.

Select  ⌘M,  or  Modify  from  the  Data  Menu  and  enter  missing
information, such as your buddy, conditions, etc....

Select ⌘S, or Save from the File Menu. The default file name will
be  formatted as yyyy_mm_dd.n, where yyyy is the year, mm is



the month, dd is the day and n is the dive number.  For example,
1995_11_25.2 would be for dive 2, November 25, 1995.



If you have more dives to download, select the desired dive on
the  watch  and  repeat.   If  Additional  information  has  been
previously entered, it will be saved across transfers so that you
don’t have to re-enter the same information for multiple dives.

4 Displaying and Editing Existing Dive Profiles

From the Finder:  Double click on the file or Drag and Drop the file
onto Hyperland.

From Hyperland: Use ⌘O, or Open from the File Menu.

Select  ⌘M,  or  Modify  from  the  Data  Menu  and  enter  missing
information, such as your buddy, conditions, etc.  The data will
carry across different Transfers, so you won’t have to re-enter it
for multiple dives.

Once  a  dive  has  been  opened,  Hyperland  will  search  for  files
matching the same date and collect them as a series.  The other
dives in the series can be opened directly from the File menu or
using Find Next Dive. Find Next Dive lets you cycle through each
of the dives in the current series.  For these features to work, the
file  names  must  follow the  Hyperland naming convention:  e.g.
“1995_07_01.2”.

The absolute dive number, the series dive number and the total
number of dives in the series is displayed in the upper right hand
corner of the dive profile.  e.g. “6 (1 of 4)”; The dive’s filename in
displayed in the upper left corner.

5 Importing Data

If  you already have files from the watch’s original PC software,
transfer  the  HGM files  to  your  Mac  (You  may  need  additional
software like “PC Exchange™”).  

Select Import PC File from the File Menu.

Save your dive profile using ⌘S, or Save from the File Menu.





6 Exporting Data

Hyperland exports three different formats:

1. Tab Separated: Data is written out to a TEXT file, the file
name will have the format yyyy_mm_dd.n.txt, each line has a
label  followed  by  the  data.   The  label  used  for  depth  and
temperature data is the relative time.  The data is suitable to
be  cut  and  pasted  into  spreadsheets  or  other  applications.
N.B.  If  a  file  with  the  same name already  exists,  it  will  be
overwritten without warning.

2. Data only: Data is written out to a TEXT file, the file name
will have the format yyyy_mm_dd.n.dat.  This file is useful for
your own plotting applications.   N.B. If a file with the same
name already exists, it will be overwritten without warning.

3. PC File: Data is written out to a TEXT file, the file name
will have the format Fnn.HGM, nn is the dive number. 

This  file  is  useful  if  you want  to  use the file  with  the watch’s
original PC software.  You may need additional software like “PC
Exchange™” to get your file to your PC or PC emulation software.
After you’ve copied the HGM file to your data directory, you will
have to edit the CNTHGM.CCC file and add an entry for your new
file. 

N.B.  If  a  file  with  the  same  name  already  exists,  it  will  be
overwritten without warning.

7 Printing

In Hyperland, select ⌘P, or Print...  from the File Menu.  

For multiple dive files, in the Finder, select the files (shift click or
drag a box around them) you want to  print  and select  ⌘P,  or
Print...  from the File Menu.





8 Viewing Options

From the View Menu, select either Metric or English to plot/view
data in metric units (meters and Celsius) or in English units (feet
and Fahrenheit).

9 Preferences

The following can be selected from the Preferences Menu:
Font and font style.  
The port being used for transfers.
Whether  to  save  or  not  save  incomplete  transfers.   When
Save  Incomplete  Transfers  is  selected,  a  file  called
"Hyperland.dbg.x" (x is the attempt number) is created which
contains data that when e-mailed to me will help me analyze
problems.

10 Troubleshooting

If transfers are not working, check that you have the correct 
cable. The correct cable to use with Hyperland is an Apple II, II 
Plus, IIe Serial Card to ImageWriter II.  Also labelled, Mac+ to 
Modem.  Apple Part# 590-0335 (beige) or 590-0556 (smoke); Cost
is about $10.00.

The Pin Configuration for this cable is:
Mini
DIN-8   DB-25
Male     Male
1          20
2          6,8
3           2
4,8         7
5           3

An indication you aren't using the proper cable is the watch will
display  ERR  almost  immediately  after  the  transfer  has  been
initiated from your MAC.   If you have a proper connection, the
watch will  display BUSY during the transfer and beep when all
data has been successfully transferred.



If  you get  the error  “Can’t  initialize serial  port”,  check that no
other  application  is  using  the serial  port.  On some Mac’s,  this
includes AppleTalk.  If AppleTalk is active, select “Inactive” from
the 



Chooser and Restart.  Also make sure that you have selected the
same port you used for the cable.  Check the Preferences Menu,
use the Select Port to select which port you have connected your
cable.

For  PowerBooks,  the  port  to  select  is  the  Modem  Port in
Hyperland even if you are connected to your printer port.

If  the  transfer  was  not  successful,  the  watch  will  display  ERR
indicating  there  was  a  communication  failure.  Hyperland  will
advise you that the watch is not responding.  In this case, reset
the watch and try again.

If you get the error “Watch is not responding”, check:

1. You are using the correct cable type.
2. The watch is properly seated in the interface cradle.
3. The serial cable must be securely plugged into the your
serial port.
4. The serial  cable  is  securely  plugged into the interface
cradle.
5. No other application is using the serial port selected; on
some Macs,  this  includes  AppleTalk.   If  AppleTalk  is  active,
select “Inactive” from the Chooser and Restart.  When using
the  modem  port,  check  that  your  modem  software  is  not
active.

If the watch displays a diver and not TR or ERR, the watch has
“timed-out” from transfer mode.  Set the watch in transfer mode
(TR) by pressing the MODE button for 2 seconds and try again.  

If you are consistently getting errors when downloading and no
dive profile is displayed, select Save Incomplete Xfers from the
Preferences Menu.  Try again and send me the Hyperland.dbg file
generated along with a note describing the dive (the date, times,
dive number etc..).

If the watch displays ERR, reset the watch to transfer mode (TR)
by pressing the MODE button once and try again.  If TR is not
displayed, press the MODE button for 2 seconds.



Send me an e-mail message if you need more technical info on
this or if you’re having communication problems.



12 Registration

Now for the business part.  A great deal of time and effort goes
into software such as this and just like the big guns, I too like to
make a profit.  After a thirty day trial period and you decide to
keep the software, please send in the US$25 registration fee.  The
registration  gets  you  free  updates  and  on-line  support.  It  also
helps defray the cost  of  development:  time,  books and on-line
costs.  Once you have paid your registration fee, you will receive
a registration number that will enable the Save, Save As, Print and
Export functions. 

Fill  out the REGISTRATION form (separate file),  or  a reasonable
facimile, and send it in along with an international money order
to:

Alex Gallico
2350 Thimens Blvd. Apt. 601
Montreal, Quebec
Canada H4R 2L7

If you supply an e-mail address it will speed up processing (saves
time and postage - paper, trees), other useful information such as
your system configuration and comments are welcome, too.  

Once you have received your registration key, you can enter it by
selecting  "About  Hyperland..."  in  the  Apple  Menu  and  then
clicking on "Register".  Enter your registration key and click on
"Register".

Contact  me  at  on  America  Online  or  CompuServe  to  report
problems/bugs or if you have questions/comments.

You  may  distribute  unregistered  copies  and  documentation  to
anyone  who  wants  it.   Ideally,  registered  copies  of  Hyperland
should be restricted for use by Registered Users only.

© 1995, Alex Gallico
America Online: AlexInCA@aol.com
CompuServe: 102371,2316


